When you are using Matomo Marketplace or updating Matomo a connection is made to matomo.org endpoints. We will soon switch this connection over to HTTPS for matomo.org and api.matomo.org. We highly recommend configuring your environment to allow HTTPS connections, otherwise these connections will fail and you won’t have access to the latest security patches, amongst other updates. If your Matomo instance is unable to support an HTTPS connection you can disable HTTPS to matomo.org and force HTTP by altering the config.ini.php as below

[General]
force_matomo_http_request = 1

As of Matomo 4.11.0 release we will update System Checks to reflect this upcoming change and give Matomo users time to prepare.

Previous FAQ: How to activate all the recommended official Matomo plugins automatically after installation? (bash script)