Are you developing a plugin for your self-hosted Matomo? Have you maybe published a plugin on the Matomo Marketplace? Then we highly recommend you read this article.

On 25th May 2018, new privacy regulations become effective called GDPR (General Data Protection Regulation) which applies to businesses worldwide. It is also known under different wordings in other countries, for example to RGPD in French and Datenschutz-Grundverordnung, DS-GVO in German.

If your plugin is storing any personal information or tracks or imports any data, we highly recommend you give the GDPR guide a read. You may also want to read our blog as we are releasing new content about GDPR regularly.

In Matomo 3.5.0, we will introduce new features for GDPR and we implemented it in a way that most – but not all – plugins will support these features out of the box without having to do anything.

Nevertheless, we recommend every plugin developer to check out our developer guide on how to make your plugin GDPR compliant to see what you need to do. A beta version of Matomo 3.5.0 is already available so you can test these new features. You can find them by logging in to your Matomo and going to “Administration => Privacy”.

Please note that any version of Piwik will not be GDPR compliant, so it is recommended that your plugin supports the latest version of Matomo (3.5.0+).


Matomo Core Team

Matomo is liberating web analytics by offering an open platform with built-in privacy. Matomo is used on more than 1 million websites worldwide and is translated in 53 languages. The Marketplace enables the community to create innovation in the world of web analytics. Roadmap - Get involved - Help & Support.


Any questions?

Many answers and more information about Matomo you can find here:

We are social

Follow us: