To all Matomo plugin developers: Matomo 4 is coming, make your plugin compatible now

We’re planning to release the first beta of Matomo 4 in a few weeks. For making it easy for Matomo users to be able to upgrade to this beta, it would be great if as many plugins on the Marketplace as possible would be already updated and compatible with Matomo 4. Then many users would be able to upgrade to the first beta without any issues.

Presumably, as you put your plugin on our Marketplace, you want people to use it. Making your plugin compatible with Matomo 4 helps ensure that people will be able to find and keep using your plugin. If your plugin is not compatible with Matomo 4, your plugin will be automatically deactivated. We’ll be happy to help you achieve compatibility should there be any issue.

How do I upgrade my Matomo to Matomo 4?

If you have installed your Matomo development environment through git you can simply checkout the Matomo 4 branch “4.x-dev” by executing these commands:

  • git checkout 4.x-dev 
  • composer install

Alternatively, you can also download the latest version directly from GitHub as a zip file and run composer install afterwards. 

How do I upgrade my plugin to Matomo 4?

While there were many breaking changes in Matomo 4, most of our Platform APIs remain unchanged, and almost all changes are for rarely used APIs. Often to make your plugin compatible it will just be a matter of adjusting the “plugin.json” file (as mentioned in the migration guide).

You can find all developer documentation on our developer zone which has already been updated for Matomo 4.

How do I know my plugin changes were released successfully?

If you have configured an email address within your “plugin.json” file, then you will receive a confirmation or an error email within a few minutes. Alternatively, you can also check out your plugin page on the Marketplace directly. If the plugin release was successful, you will see additional links below the download button showing which versions your plugin is compatible with.

What it looks like when your plugin is compatible with multiple Matomo versions

How can I downgrade to Matomo 3 or switch between Matomo 3 and Matomo 4?

To downgrade from Matomo 4 to Matomo 3:

When will the final Matomo 4 release be available?

We estimate the final stable Matomo 4.0.0 release will be released in approx. 3 months.

What’s new in Matomo 4?

We don’t have a summary of the changes available just yet but you can see all closed issues within this release here.

Any questions or need help? 

If you have any questions, or experience any problems during the migration don’t hesitate to  get in touch with us. We’ll be happy to help get your plugin compatible and the update published. If you find any undocumented breaking change or find any step during the migration process not clear, please let us know as well.

Thank you for contributing a plugin to the Marketplace and making Matomo better. We really appreciate your work!

Share this post

Share on facebook
Share on twitter
Share on linkedin
Share on print
Share on email